RaspberryPi3(Raspbian)でPython3版ZeroMQを使う方法

研究の関係でRaspberryPi3同士で通信させる必要が生じたのでPython3版のZeroMQを導入。。。しようとしたが問題発生。

「How to install ZeroMQ on Raspberry Pi」https://github.com/MonsieurV/ZeroMQ-RPiを参考にインストールしようとするも途中でエラーが発生してしまい、完了できない。

しかも、試行錯誤の末できたと思ったらPython2版だったという悲劇。

で、どうやったらインストールできるんだ!!と頭抱えて思いついた。もしかして他のモジュールみたいにXXX-python3で行けるのでは???

行けました。

$sudo apt-get zmq-python3

これでインストールできた。なんとシンプルな。

コメントを残す